Beefy Boxes and Bandwidth Generously Provided by pair Networks Cowboy Neal with Hat
Syntactic Confectionery Delight
 
PerlMonks  

Re: Creating thumbnail solution help

by tonyc (Pilgrim)
on Mar 05, 2010 at 22:36 UTC ( #827078=note: print w/ replies, xml ) Need Help??


in reply to Creating thumbnail solution help

Posting the code you're using and a link to one of the problematic images would be useful.


Comment on Re: Creating thumbnail solution help
Re^2: Creating thumbnail solution help
by uG (Scribe) on Mar 06, 2010 at 01:16 UTC
    Here is an image: http://img707.imageshack.us/img707/2011/picture066q.jpg The code im using is
    sub thumbnail :Regex('^thumbnail/(.+)') { my ($self, $c) = @_; my $image_id = $c->req->captures->[0]; $image_id =~ s/\//\\/g; my $image_obj = $c->model('File')->slurp($image_id) or $c->detach('/default'); $c->stash->{scaling} = 'fit'; $c->stash->{x} = 100; $c->stash->{image} = $image_obj; $c->forward('View::Thumbnail'); }
    It can also be seen on the author's site here: http://perl.jonallen.info/writing/articles/creating-thumbnails-with-catalyst It opens the file using Catalyst::Model::File. I don't see any parameters to set it to binary, so maybe that is why. But the tutorial on the author's page above doesn't mention anything about having to set the file model to binary so I dunno...
      It is indeed a problem with Imager or the jpeg library it uses. I don't know if its only on a windows platform or not though. Instead i've wrote a catalyst view that uses Image::Resizer instead of Catalyst::View::Thumbnail which uses Imager.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://827078]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others musing on the Monastery: (11)
As of 2014-04-18 12:04 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (466 votes), past polls