Beefy Boxes and Bandwidth Generously Provided by pair Networks Cowboy Neal with Hat
good chemistry is complicated,
and a little bit messy -LW
 
PerlMonks  

Re^2: XML::Simple giving a non-specific error

by liverpole (Monsignor)
on Mar 12, 2010 at 00:28 UTC ( #828170=note: print w/ replies, xml ) Need Help??


in reply to Re: XML::Simple giving a non-specific error
in thread XML::Simple giving a non-specific error

... if you change

$XML::Simple::PREFERRED_PARSER = 'XML::Parser';
to
$XML::Simple::PREFERRED_PARSER = 'XML::LibXML::SAX';

That output certainly looks more like what I want, even though I never said my code contained:

$XML::Simple::PREFERRED_PARSER = 'XML::Parser';
I've just installed XML::SAX with ppm, but the addition of this line:
$XML::Simple::PREFERRED_PARSER = 'XML::LibXML::SAX';
throws the error:
Can't locate object method "new" via package "XML::SAX" at C:/Perl/sit +e/lib/XML/ SAX/ParserFactory.pm line 41, <DATA> line 13.

But thanks, that does give me an alternative that I can do more research on.   And as I said, the XML is really basic (and reasonably short), so I'm quite certain speed won't be an issue.

Update:  On a hunch I tried "ppm install XML::LibXML::SAX", and that got me past the "Cannot locate object" error above.  Now I'm getting a much nicer error message:

Error while parsing XML: Opening and ending tag mismatch: ERROR line 8 and ROOT Premature end of data in tag ERROR line 8 Premature end of data in tag ROOT line 3 at C:/Perl/site/lib/XML/LibXM +L/SAX.pm l ine 64 at C:/Perl/lib/XML/Simple.pm line 370

So ++thanks again; it appears to fit my needs nicely.


s''(q.S:$/9=(T1';s;(..)(..);$..=substr+crypt($1,$2),2,3;eg;print$..$/


Comment on Re^2: XML::Simple giving a non-specific error
Select or Download Code
Re^3: XML::Simple giving a non-specific error
by ikegami (Pope) on Mar 12, 2010 at 01:07 UTC

    I never said my code contained $XML::Simple::PREFERRED_PARSER = 'XML::Parser';

    I realise it wasn't there explicitly, but by virtue of not setting it explicitly and having XML::Parser installed, it's as if you had.

    Can't locate object method "new" via package "XML::SAX

    Hum, weird. Did you also install XML-LibXML to provide XML::LibXML::SAX? It would be a bad failure mode if not having XML::LibXML::SAX is the cause of that error, but you never know.

    ( I see from your update that this was indeed the problem )

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://828170]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (5)
As of 2014-04-20 13:31 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (485 votes), past polls