Beefy Boxes and Bandwidth Generously Provided by pair Networks
more useful options
 
PerlMonks  

Re^3: Is there a way to upgrade a module by one version level via cpan, but not the latest version?

by marto (Chancellor)
on Mar 29, 2010 at 12:49 UTC ( #831619=note: print w/ replies, xml ) Need Help??


in reply to Re^2: Is there a way to upgrade a module by one version level via cpan, but not the latest version?
in thread Is there a way to upgrade a module by one version level via cpan, but not the latest version?

"So then, the answer is no?

No, the answer given works.

"There isn't a way to do it via the cpan commandline?"

Yes, as previously advised by ikegami:

cpan> install RKINYON/DBM-Deep-1.0014.tar.gz


Comment on Re^3: Is there a way to upgrade a module by one version level via cpan, but not the latest version?
Download Code
Re^4: Is there a way to upgrade a module by one version level via cpan, but not the latest version?
by Hue-Bond (Priest) on Mar 29, 2010 at 13:03 UTC

    I think (s)he's talking about a cpan command line parameter, just like this:

    $ cpan RKINYON/DBM-Deep-1.0014.tar.gz

    (which appears to work just fine in my box).

    --
     David Serrano
     (Please treat my english text just like Perl code, i.e. feel free to notify me of any syntax, grammar, style and/or spelling error. Thank you!).

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://831619]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others imbibing at the Monastery: (13)
As of 2014-08-22 15:22 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (159 votes), past polls