Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Re^2: www::mechanize not behaving as browser?

by jonnyfolk (Vicar)
on Jul 24, 2010 at 10:54 UTC ( #851149=note: print w/ replies, xml ) Need Help??


in reply to Re: www::mechanize not behaving as browser?
in thread www::mechanize not behaving as browser?

Hi, thanks for your comment - I am taking a look at Wireshark now.

I have tried several different browsers include IE & Firefox on Windows and Safari, Firefox and even Camino on Mac, and all have achieved successful search results. It doesn't seem too fussy about the particular browser, but there's obviously something different in my Mechanize browser which is sending things awry.


Comment on Re^2: www::mechanize not behaving as browser?
Re^3: www::mechanize not behaving as browser?
by Anonymous Monk on Jul 24, 2010 at 12:12 UTC
    If it isn't filtering by the user-agent string, its probably setting a cookie via img (which mechanize doesn't load), or some form value via script... so it could be as simple as fetching an image, or set some extra form values normally set via script ... it all shows up on the wire :)

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://851149]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (18)
As of 2014-08-01 13:14 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    Who would be the most fun to work for?















    Results (20 votes), past polls