Beefy Boxes and Bandwidth Generously Provided by pair Networks
Your skill will accomplish
what the force of many cannot
 
PerlMonks  

Re^11: broke my perl? :(

by rowdog (Curate)
on Aug 27, 2010 at 13:57 UTC ( #857688=note: print w/ replies, xml ) Need Help??


in reply to Re^10: broke my perl? :(
in thread broke my perl? :(

I'm not sure that it's necessary to fix your Ubuntu installation but you will probably run into problems down the road if you don't. It used to be that your package manager would be broken by now but apt has been moving away from the perl dependency so you might not ever notice. At the very least, perl programs installed through the package manager will be broken.

You can check the system perl with
/usr/bin/perl -v
which should say something like
This is perl, v5.10.1 (*) built for x86_64-linux-gnu-thread-multi
You can also check to see what kind of file it is with
file /usr/bin/perl
which should say something like
/usr/bin/perl: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dy +namically linked (uses shared libs), for GNU/Linux 2.6.18, stripped
If your system doesn't give similar responses, your system perl is broken.


Comment on Re^11: broke my perl? :(
Select or Download Code

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://857688]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (6)
As of 2014-08-29 00:46 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (275 votes), past polls