Beefy Boxes and Bandwidth Generously Provided by pair Networks vroom
Perl-Sensitive Sunglasses
 
PerlMonks  

Re^2: Do Pure Perl CPAN packages really need to use ExtUtils::Command::MM?

by Anonymous Monk
on Apr 05, 2011 at 17:44 UTC ( #897565=note: print w/ replies, xml ) Need Help??


in reply to Re: Do Pure Perl CPAN packages really need to use ExtUtils::Command::MM?
in thread Do Pure Perl CPAN packages really need to use ExtUtils::Command::MM?

it works fine on perl 5.005 if you can install a few additional modules
If that is the case, then why does Module::Build require a Perl of at least 5.6.1? The Changes file says that requirement was added in 2008.


Comment on Re^2: Do Pure Perl CPAN packages really need to use ExtUtils::Command::MM?
Re^3: Do Pure Perl CPAN packages really need to use ExtUtils::Command::MM?
by jethro (Monsignor) on Apr 06, 2011 at 12:10 UTC

    I couldn't find a 'require version' or 'use version' line in the source code of Module::Build. There is only that single line in the changelog. You might ask schwern about it or send the maintainers a bug report. The documentation only says that since 5.6.0 all prerequisites are included in core, but works fine on 5.005.

    Anyway, does that change much? Companies that still use a pre-5.6.0 versions are usually so conservative that they don't allow any modules from CPAN anyway

      Look at the first line of Module::Build's Build.PL or Makefile.PL.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://897565]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (10)
As of 2014-04-18 22:20 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (472 votes), past polls