Beefy Boxes and Bandwidth Generously Provided by pair Networks
Clear questions and runnable code
get the best and fastest answer
 
PerlMonks  

Re^3: Arguments for upgrading from Perl 5.8

by chromatic (Archbishop)
on Nov 17, 2011 at 22:20 UTC ( #938691=note: print w/ replies, xml ) Need Help??


in reply to Re^2: Arguments for upgrading from Perl 5.8
in thread Arguements for upgrading from Perl 5.8

Only as of 5.14 are most of the builtin operations fully aware of Unicode; too many of them default to assuming the semantics of whatever the local character set is. unicode mentions this as "The Unicode Bug". Perl 5.12 fixed some of that, but only as of Perl 5.14 can you use use feature 'unicode_strings'; to get Perl to do the right thing.

I haven't encountered huge problems in my work, but most of what I do uses nothing more exotic than Latin-1 and UTF-8, so I've been fortunate. Then again, everything I care about runs on Perl 5.14.1 (and soon Perl 5.14.2).


Improve your skills with Modern Perl: the free book.


Comment on Re^3: Arguments for upgrading from Perl 5.8
Download Code

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://938691]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others examining the Monastery: (17)
As of 2014-07-31 20:00 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (252 votes), past polls