Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Page rendering bugs

by kimmel (Beadle)
on Jul 14, 2012 at 15:45 UTC ( #981825=monkdiscuss: print w/ replies, xml ) Need Help??

I just found these rendering bugs while browsing around PM. Here are the screens:

I noticed these because PM suddenly had a horizontal scroll bar. I looked for a mass message form for the janitors and could not find one. Do only the gods have that feature? I messaged the janitors that were on the site at the time.

Update: No problems on Android or with Opera Mobile.

Comment on Page rendering bugs
Re: Page rendering bugs
by bulk88 (Priest) on Jul 14, 2012 at 17:01 UTC

      duplicate perl environments uses <pre> tags, which are a longstanding problem, not just in PerlMonks, but just about everywhere. If it's a big problem you could specify in your CSS that pre blocks should be constrained to a maximum size, and should be scrollable. Twitter Bootstrap offers this CSS option, for example.


      Dave

        The other part of the problem is people front-paging nodes that have haznav problems.

        We should just fix 'pre' tags so that they aren't a problem, of course.

        I complained to the author about how horrible the table in Inner Scriptorium was. He seemed uninterested in fixing it. I mostly considered it his loss (in keeping his thread rather unreadable; though not to him). Ruining the rendering of an "inner" section is only a little more bothersome. I should put a 'readmore' around the table, though.

        - tye        

        Another CSS alternative exists (an alternative using CSS to address this horizontal-scrolling problem).

        davido offered:

        duplicate perl environments uses <pre> tags, which are a longstanding problem, not just in PerlMonks, but just about everywhere. If it's a big problem you could specify in your CSS that pre blocks should be constrained to a maximum size, and should be scrollable.

        How-dy! It ought to noted that few formatting mishaps on Perlmonks are as irritating to me (and considerable other users) as long-line posts (horiz. scrolling). The <pre> tag is indeed deprecated at Perlmonks, but is it a reasonable expectation that most users without long experience here will remember that? Plus, is it (apparently) true that users diligently check the markup they are using against the Monastery guidelines? Point taken perhaps without me going on and on about user behavior ...

        A code solution always seems attractive when one can be found. Here's one for the PRE problem on Perlmonks nodes:

        /* style frag CSS */ pre { white-space : pre-wrap }

        The pre-wrap is defined at w3.org as doing:

        This value prevents user agents from collapsing sequences of white space. Lines are broken at newlines in the source, at occurrences of "\A" in generated content, and as necessary to fill line boxes.
        and is from the CSS Level 2 spec.

        I am not on the inside wrt nuts and bolts of the Everything machine and the production of markup on PMo. So I have to leave it to someone else to work out the best way to actually implement the application of a default style setting (that is different from the default in most user agents). But a simple approach would be to just change the Common CSS for all Themes.

Re: Page rendering bugs
by Athanasius (Monsignor) on Jul 14, 2012 at 17:14 UTC

    On Windows Vista 32-bit:

    • Front page rendering problem confirmed on IE 9. No rendering problem for Inner Scriptorium.
    • No rendering problems observed on Opera 12, Google Chrome 20, or Mozilla Firefox 13.

    Update: I’m unable to reproduce the reflow error by resizing the window when viewing Inner Scriptorium on any of the above-mentioned browsers.

    Athanasius <°(((><contra mundum

      The Inner Scriptorium problem happens on firefox as you shrink the window down. Big enough to fit all the content no problem, too small and you should get a reflow error.
Re: Page rendering bugs (IE?)
by tye (Cardinal) on Jul 14, 2012 at 19:07 UTC

    None of that looks like something specific to IE. Perhaps your other browsers have overrides for the default (also known as "standard") behavior of 'pre' tags? Or perhaps the 'pre' tags were fixed by the time you stopped testing with IE versions?

    - tye        

      I used browsershots - perlmonks to occasionally snap screens for IE. It just so happened that those issues showed up today. Firefox 13 worked and a quick check in chromium 22.0.1190.0 (144885) did not show that problem either. The chromium was a clean install no plugins while firefox was the version I use everyday.

        It seems like the default behavior for 'pre' tags has simply changed in modern browsers (and quite recently). You checked lots of old versions of IE. It doesn't look like you are looking at even a second version of any other browsers. I believe it is not an "IE" problem; it is a relatively new browser change. I don't know if that is motivated by a standard change or just a practical improvement.

        - tye        

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: monkdiscuss [id://981825]
Approved by moritz
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others perusing the Monastery: (16)
As of 2014-11-24 15:16 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My preferred Perl binaries come from:














    Results (142 votes), past polls