Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number
 
PerlMonks  

Tk not supported in ActiveState Perl 5.14+

by slugger415 (Beadle)
on Aug 24, 2012 at 13:38 UTC ( #989534=perlquestion: print w/ replies, xml ) Need Help??
slugger415 has asked for the wisdom of the Perl Monks concerning the following question:

Hello monks, I am distressed to see that the Tk module is not supported in later versions of the ActiveState version of Perl http://code.activestate.com/ppm/Tk/. I have new users wanting to use a script I wrote a few years ago that are unable to install the module. What are my choices? I see a module called Tkx but know nothing about it -- would it be difficult to port my script over to that? I also use Tk::Dialog which isn't in the list.

Thank you.

Comment on Tk not supported in ActiveState Perl 5.14+
Re: Tk not supported in ActiveState Perl 5.14+
by daxim (Chaplain) on Aug 24, 2012 at 13:47 UTC
      Thanks, this is useful! Scott
Re: Tk not supported in ActiveState Perl 5.14+
by aitap (Deacon) on Aug 24, 2012 at 14:28 UTC
Re: Tk not supported in ActiveState Perl 5.14+
by zentara (Archbishop) on Aug 24, 2012 at 14:38 UTC
Re: Tk not supported in ActiveState Perl 5.14+
by bulk88 (Priest) on Aug 24, 2012 at 20:16 UTC
    Tkx and Perl Tk are not compatible. Different APIs. As other said, look for a different PPM repository, ActiveState's build farm is notorious for not working.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://989534]
Approved by toolic
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (9)
As of 2014-11-29 01:16 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My preferred Perl binaries come from:














    Results (200 votes), past polls