Beefy Boxes and Bandwidth Generously Provided by pair Networks
No such thing as a small change
 
PerlMonks  

Re: Asynchronous HTTP requests and (digest) authentication

by daxim (Chaplain)
on Sep 11, 2012 at 12:07 UTC ( #992981=note: print w/ replies, xml ) Need Help??


in reply to Asynchronous HTTP requests and (digest) authentication

non-blocking solution [Ö] that works well inside a Glib loop
Then the obvious module is libsoup, isn't it?


Comment on Re: Asynchronous HTTP requests and (digest) authentication
Re^2: Asynchronous HTTP requests and (digest) authentication
by Ralesk (Pilgrim) on Sep 11, 2012 at 12:22 UTC

    Thanks, that looks interesting ó I hope the Perl module is mature enough.

Re^2: Asynchronous HTTP requests and (digest) authentication
by Ralesk (Pilgrim) on Sep 11, 2012 at 13:59 UTC

    And hahaha, no.

    Would be awesome, but it requires Glib::Object::Introspection which requires gobject-introspection 0.10.0 or newer, which requires a Glib slightly higher than what we unfortunately have to aim for (Iím a bit afraid of building a newer glib and toppling over the entire Gtk+ stack as a result...)

    Ah, the bane of having to run on older system releases :(

      requires Glib::Object::Introspection ..... (Iím a bit afraid of building a newer glib and toppling over the entire Gtk+ stack as a result...

      There is no requirement for you to go to the newest libsoup gtk3 libs, except maybe some methods may be changed or missing. You could go back and get the libsoup that was compatible with your current gtk2 libs. Another option may be webkit. A Perl module exists to use it, but I don't know if it would handle your authentication requirements.

      You can go back into the older directories at gnome sources, to find your compatible version. It looks like libsoup goes way back into gtk2 versions before Glib::Object::Introspection even showed up on the scene.

      The switch from gtk2 to gtk3 occurred at GTK+ 2.24. So I would start with the libsoup with the ftp date closest to 2.24. Libs after that point are still gtk3 although they have a 2.xx number.


      I'm not really a human, but I play one on earth.
      Old Perl Programmer Haiku ................... flash japh

        The first Glib::Object::Introspection ever (0.001) already requires GObject-Introspection 0.10.0 (we have 0.6.14), which requires Glib 2.24 (and we have 2.22.5). The Gtk is a disgracefully old 2.18 so it might not like the new Glib entirely, though I havenít tested that ó but I donít want to cause instability on these machines (not to mention, upgrading packages them all would be a mess).

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://992981]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (13)
As of 2014-08-21 16:03 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (136 votes), past polls