Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

Re^5: LWP Can't POST to HTTPS

by dorko (Parson)
on Sep 12, 2012 at 17:47 UTC ( #993268=note: print w/ replies, xml ) Need Help??


in reply to Re^4: LWP Can't POST to HTTPS
in thread LWP Can't POST to HTTPS

Can you please tell me how to enable trace/debug? I found LWP::Debug, but that's depreciated.

Cheers,

Brent

-- Yeah, I'm a Delt.


Comment on Re^5: LWP Can't POST to HTTPS
Re^6: LWP Can't POST to HTTPS
by Anonymous Monk on Sep 12, 2012 at 17:56 UTC

    From Long delay with Crypt::SSLeay and LWP, the thing you linked and read and tried a "solution" from, the diagnostic steps

    #!/usr/bin/perl -- use LWP::Simple ; use IO::Socket::SSL qw(debug3); get( q{https://pilot-payflowpro.paypal.com/} ); get( q{https://xxxx.ucf.edu} ); __END__
      Mea maxima culpa. I'm sorry, when I said "looking at" I should have said "skimmed". Admittedly, I didn't read that. Thank you.

      This is the results of IO::Socket::SSL qw(debug3); for the POST.

      DEBUG: .../IO/Socket/SSL.pm:1645: new ctx 32651216 DEBUG: .../IO/Socket/SSL.pm:363: socket not yet connected DEBUG: .../IO/Socket/SSL.pm:365: socket connected DEBUG: .../IO/Socket/SSL.pm:383: ssl handshake not started DEBUG: .../IO/Socket/SSL.pm:446: Net::SSLeay::connect -> -1 DEBUG: .../IO/Socket/SSL.pm:1320: SSL connect attempt failed with unkn +own error error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/SSL.pm:452: fatal SSL error: SSL connect attempt +failed with unknown error error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/SSL.pm:1320: IO::Socket::INET configuration faile +d error:00000000:lib(0):func(0):reason(0) DEBUG: .../IO/Socket/SSL.pm:1682: free ctx 32651216 open=32651216 DEBUG: .../IO/Socket/SSL.pm:1690: OK free ctx 32651216
      Again, any help will be appreciated. Thanks for your time.

      Cheers,

      Brent

      -- Yeah, I'm a Delt.

        Looks to me like you edited that. I get

        DEBUG: .../IO/Socket/SSL.pm:354: ssl handshake not started DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18003144 DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18832752 DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18830608 DEBUG: .../IO/Socket/SSL.pm:1555: ok=1 cert=18829200 DEBUG: .../IO/Socket/SSL.pm:1170: scheme=www cert=18829200 DEBUG: .../IO/Socket/SSL.pm:1177: identity=webcourses.ucf.edu cn=webco +urses.ucf.edu alt=2 webcourses.ucf.edu DEBUG: .../IO/Socket/SSL.pm:414: Net::SSLeay::connect -> 1

        Sure I'm using an older version of IO::Socket::SSL ( 1.58 ) compiled against older version of OpenSSL , but I doubt that makes a difference

Re^6: LWP Can't POST to HTTPS
by Anonymous Monk on Sep 12, 2012 at 17:58 UTC

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://993268]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others about the Monastery: (14)
As of 2015-07-06 13:11 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (74 votes), past polls