|No such thing as a small change|
I think almost everything was said in this node (some other interesting things could be found here)
Now For my part, chating with tilly convinced me that explicit function name, (and obviously code logic)
is definitly something to pay attention to
(mainly beccause of the code/comments synchronization problem):
For example your function could be renamed db_check_user_address()
Anyway even if it's obvious :
Pay more attention in writing clear code rather than trying to explain complex/strange/bad/obscure code.
NOTE: I've heard dkubb is working on a document, describing good coding practice, needless to say I'm impatient to read it...
(Especially when you see the quality of some of this post...)
Furthermore I see more and more questions about how to write good code? what is more elegant? how much a code should be documented? ...
I then think I'm not the only one who find perlstyle a little bit short.
And I really think that with all the skilled coders around, the monastery could produce a good answer...
"Only Bad Coders Badly Code In Perl" (OBC2IP)