http://www.perlmonks.org?node_id=1001359


in reply to Perl QtCore4 won't install

That distro is outdated. Check out code from the official repository instead. You didn't say what version of Qt you are running, so I'm linking to the main branch.

As with any C-library, you need the appropriate header files from the packages libsmokeqt-devel and libqt4-devel at the least. These are the OpenSUSE names, you need to figure out the debianised equivalents yourself.