http://www.perlmonks.org?node_id=1089514


in reply to Is maintaining multiple versions of a CPAN module a terrible idea?

Others have pointed out some stuff about how the indexer works. If the existing module is Foo::Bar and you want both that and the new one to be indexed you'd probably want to release the incompatible modernist version as something like Foo::Bar2. See Dancer and Dancer2.

Until a few years ago I would have agreed with you that maintaining backward compatibility was important - although I wouldn't go so far as to support 5.002, I used to strive to support 5.6.2. But these days I don't bother. That's what CP5.6.2AN and its many friends and relations are for.