I'd argue that zip() isn't that readable to begin with! *grins*
I guess I could rename it '¥' :)
Or maybe you'd prefer map_one_element_from_each_of_two_arrays_at_a_time()?
Or should that be map_one_element_at_a_time_from_each_of_two_arrays()?
Plus, can't you use some variant of reduce() or mapcar() to achieve the same thing?
Not that I am aware off. Anoyone know a better implementation?
Also, isn't the subref prototype prone to memory leaks?
Again. Not that I am aware of. Maybe the problem lies in the module?