if (really_long_and_boring_condition) do_something_useful()
to be much harder to read in C. Plus, people seem to feel that just cause you don't have braces means you don't have to follow proper indentation practices. (Not that braces always help, but it allows me to bounce on % in (g)vi(m).)
Personally, I prefer the following alternatives:
do_something_useful() if really_long_and_boring_condition; # Or ... really_long_and_boring_condition && do_something_useful();
Depending on which is more important to understanding the program's flow.
Being right, does not endow the right to be rude; politeness costs nothing.
Being unknowing, is not the same as being stupid.
Expressing a contrary opinion, whether to the individual or the group, is more often a sign of deeper thought than of cantankerous belligerence.
Do not mistake your goals as the only goals; your opinion as the only opinion; your confidence as correctness. Saying you know better is not the same as explaining you know better.