http://www.perlmonks.org?node_id=660709


in reply to Re^2: Experience with ActivePerl 5.10 vs. 5.8 PPM incompability
in thread Experience with ActivePerl 5.10 vs. 5.8 PPM incompability

So I guess i'll have to try the other option in Upgrading from ActivePerl 5.8.x

No - those instructions relate to upgrading from one version of perl 5.8.x to a more recent version of perl 5.8.x. But they don't apply to upgrading from 5.8.x to 5.10.x.

In step 2, the site/lib directory also needs to be deleted since it could (and almost certainly would) contain modules that are binary-incompatible with 5.10.

Cheers,
Rob