http://www.perlmonks.org?node_id=900873

hsmyers has asked for the wisdom of the Perl Monks concerning the following question:

Just got bitten by what I presume is an old error--- new to me however. The: "The distribution contains the following world writable directories or files and is therefore considered a security breach and as such not being indexed" when uploading to my PAUSE account. Since I'm using reasonably current modules:
Windows Vista Home Premium C:\>version Module::Build Module::Build version 0.3601 C:\>version Archive::Tar Archive::Tar version 1.54 C:\>perl -v This is perl, v5.10.1 built for MSWin32-x86-multi-thread
I'm somewhat at a loss to understand the directions in either the article on use.perl.org or the secondary link to the monastery Re: Creating CPAN distribution on Win32 with Module::Build. I would assume that the fault lies in the parameterization of the make dist command, but I lack the necessary foo to either fix this or the .gz file created. It may also have to do with the fact that the ancestor of the current makefile.pl was created by h2xs 1.21; again, I'm out of my depth here. This is of some concern as I've other modules to upload and won't do so until I can proceed with out error. Anybody know the fix or a fix? Bear in mind that I've no problem making significant changes to the scheme of things (i.e. even trying new approaches to module creation).

--hsm

"Never try to teach a pig to sing...it wastes your time and it annoys the pig."