http://www.perlmonks.org?node_id=929149
RobbieSnr has asked for the wisdom of the Perl Monks concerning the following question:

I have a Mac and prior to installing Lion I had both the native Perl 5.10 and ActivePerl 5.8 installed. I use MAMP PRO to set up virtual hosts so that I can test some CGI scripts on the Mac before uploading them to the live server. I use DB_File to save data in Berkeley DB files and found that those files set up with 5.8 could be read by 5.10. Since upgrading to Lion that now uses 5.12 I find that 5.12 won't read the files set up with 5.8.

Does anyone know why this is?