http://www.perlmonks.org?node_id=836488


in reply to Re^4: A wholly inadequate reply to an Anonymous Monk
in thread A wholly inadequate reply to an Anonymous Monk

Yes, and you don't break backwards compatiblity. Which is what AnonMonk was talking about.

If you use a menchanism like use $version or use feature there's no need to call it a major new version of perl. We already have these incremental language modifications in perl 5, which AnonMonk wished that Perl 6 would bring them.

That said, perl 5.10 still breaks backwards compatibility in several ways (introducing new operators, changed scoping of regex modifiers), even though it was "only" a bump in the minor version number. Even if it were possible in theory to avoid that, it would be a huge maintenance burden to ship two regex engines with different scoping rules, which are then swapped depending on the presence of a pragma.