Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Issues with installing Inline::Python

by sbc (Initiate)
on May 20, 2013 at 20:34 UTC ( #1034401=perlquestion: print w/replies, xml ) Need Help??

sbc has asked for the wisdom of the Perl Monks concerning the following question:

Hello,

I am trying to install CPAN Inline::Python, so I can use python code inside of my perl script. I am seeing the following error, and not sure what may be the problem. Any help will be appreciated.

I did the following, based on http://www.cpan.org/modules/INSTALL.html

1. set http_proxy to mycorp proxy server 2. set ftp_proxy to mycorp proxy server. 3. cpan App::cpanminus
error is as below:

Fetching with LWP: ftp://ftp.wayne.edu/cpan/modules/03modlist.data.gz Going to read /nfs/pdx/disks/nehalem.pde.252/hsw/tvpv/user_dir/sbharg2 +/perlcpan/sources/modules/03modlist.data.gz Going to write /nfs/pdx/disks/nehalem.pde.252/hsw/tvpv/user_dir/sbharg +2/perlcpan/Metadata Running install for module App::cpanminus Running make for M/MI/MIYAGAWA/App-cpanminus-1.6915.tar.gz Fetching with LWP: file://ftp.uwsg.iu.edu/pub/perl/CPAN/authors/id/M/MI/MIYAGAWA/App-cp +anminus-1.6915.tar.gz LWP failed with code[404] message[File `//ftp.uwsg.iu.edu/pub/perl/CPA +N/authors/id/M/MI/MIYAGAWA/App-cpanminus-1.6915.tar.gz' does not exis +t] Fetching with LWP: ftp://ftp.wayne.edu/cpan/authors/id/M/MI/MIYAGAWA/App-cpanminus-1.69 +15.tar.gz CPAN: Digest::MD5 loaded ok Fetching with LWP: file://ftp.uwsg.iu.edu/pub/perl/CPAN/authors/id/M/MI/MIYAGAWA/CHECKS +UMS Fetching with LWP: file://ftp.uwsg.iu.edu/pub/perl/CPAN/authors/id/M/MI/MIYAGAWA/CHECKS +UMS.gz Fetching with LWP: ftp://ftp.wayne.edu/cpan/authors/id/M/MI/MIYAGAWA/CHECKSUMS Checksum for /nfs/pdx/disks/nehalem.pde.252/hsw/tvpv/user_dir/sbharg2/ +perlcpan/sources/authors/id/M/MI/MIYAGAWA/App-cpanminus-1.6915.tar.gz + ok Scanning cache /nfs/pdx/disks/nehalem.pde.252/hsw/tvpv/user_dir/sbharg +2/perlcpan/build for sizes App-cpanminus-1.6915/ App-cpanminus-1.6915/bin/ App-cpanminus-1.6915/Changes App-cpanminus-1.6915/cpanfile App-cpanminus-1.6915/lib/ App-cpanminus-1.6915/LICENSE App-cpanminus-1.6915/Makefile.PL App-cpanminus-1.6915/MANIFEST App-cpanminus-1.6915/MANIFEST.SKIP App-cpanminus-1.6915/META.json App-cpanminus-1.6915/META.yml App-cpanminus-1.6915/README App-cpanminus-1.6915/t/ App-cpanminus-1.6915/t/happy_cpantesters.t App-cpanminus-1.6915/lib/App/ App-cpanminus-1.6915/lib/App/cpanminus.pm App-cpanminus-1.6915/bin/cpanm CPAN.pm: Going to build M/MI/MIYAGAWA/App-cpanminus-1.6915.tar.gz ExtUtils::MakeMaker version 6.3 required--this is only version 6.17 at + Makefile.PL line 7. BEGIN failed--compilation aborted at Makefile.PL line 7. Running make test Make had some problems, maybe interrupted? Won't test Running make install Make had some problems, maybe interrupted? Won't install

Replies are listed 'Best First'.
Re: Issues with installing Inline::Python
by davido (Cardinal) on May 20, 2013 at 21:00 UTC

    Everything you've shown has to do with installing cpanminus, not Inline::Python. You may discover Inline::Python issues next, but not until you've gotten past getting a CPAN installer up and running. If you do want to use cpanminus to do your CPAN installs, be sure to read the documentation: App::cpanminus. There you'll find tips for a simple installation of this utility, which differ from the strategy you're following.

    If the steps listed in the module's documentation still fail to result in a successful installation of App::cpanminus, follow up here with an explanation of the failure as it applies to your following the official instructions.

    Update: If you don't have proper permissions you can always use perlbrew and local::lib to set up your own library where you do have permissions. But then when you go to production you'll run into the problem of not having the necessary dependencies, and not having made prior arrangements to have them installed. The problem won't go away until that gets resolved.


    Dave

Re: Issues with installing Inline::Python
by Anneq (Vicar) on May 20, 2013 at 20:43 UTC

    Try the following to bring it up to the latest version, and your error may go away:

    $ cpan ExtUtils::MakeMaker

    Anne

      Unfortunately, I do not have root permissions to write to the standard perl path used by mycorp. Hence, i see this error at the end:
      /usr/bin/make test -- OK Running make install !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! ERROR: Can't create '/usr/bin' Do not have write permissions on '/usr/bin' !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! +!! at -e line 1 make: *** [pure_perl_install] Error 255 /usr/bin/make install -- NOT OK You may have to su to root to install the package

        Try this:

        $ cpan cpan>look ExtUtils::MakeMaker [/path/to/the/module/build/directory]#

        If the path to the build directory is not under your user directory, then you will have to download the CPAN tar.gz file into a directory and unpack it. Then:

        $ cd /path/to/the/module/build/directory $ perl Makefile.PL $ make $ make test $ make install

        I'm not an expert with CPAN or modules, so I don't know if this will work for you. Good luck.

        Anne

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: perlquestion [id://1034401]
Approved by toolic
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others lurking in the Monastery: (1)
As of 2022-05-19 03:41 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Do you prefer to work remotely?



    Results (71 votes). Check out past polls.

    Notices?