http://www.perlmonks.org?node_id=1079971


in reply to Re^2: JSON 2.5 2.90
in thread JSON 2.5 2.90

JSON::XS requires JSON, so cpan is trying to load JSON to make sure you have it. You have configured JSON to use JSON::XS which isn't installed, so JSON doesn't load.

The solution is to stop telling JSON to use JSON::XS until you've installed JSON::XS. The following installed JSON::XS, after which you'll be fine:

PERL_JSON_BACKEND= cpan JSON::XS