Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Perl install ignores -Dprefix

by Anonymous Monk
on May 22, 2014 at 14:08 UTC ( #1087104=perlquestion: print w/replies, xml ) Need Help??

Anonymous Monk has asked for the wisdom of the Perl Monks concerning the following question:

I configure like :
/configure.gnu -de -Dprefix=/app/perl -Dusethreads -Duse64bitall -Dcc= +/app/sfw/gcc
when it comes to install it dumps everything in /app, not /app/perl. Why?

Replies are listed 'Best First'.
Re: Perl install ignores -Dprefix
by Corion (Pope) on May 22, 2014 at 14:14 UTC

    The proper way to configure Perl is not to call ./configure.gnu but ./Configure:

    /bin/sh ./Configure -de -Dprefix=/app/perl -Dusethreads -Duse64bitall +-Dcc=/app/sfw/gcc
      Thanks, I did this and still everything being dumped into /app. Any suggestions, there's nothing in makefile with /app/perl
        Is /app/perl a directory? I usually unpack a perl tarball then rename the directory to the perl version number that I just unpacked as the installation prefix. For example:
        mv /opt/perl444-27-O1-5.20.0-RC1 /opt
        perl444 stands for perl using gcc-4.4.4; the 27 represents the OS which is the 2.6.27 kernel; O1((that's capital O followed by 1) stands for the optimization flag that I will use; lastly, the version number which I'm using. Next, you probably should set the path for your compiler and its library:
        export CC=/opt/444/bin/gcc export LD_LIBRARY_PATH=/usr/local/lib
        Then change directory:
        cd /opt/perl444-27-O1-5.20.0-RC1
        Now, following Corion's advice:
        ./Configure -Dcc=/opt/444/bin/gcc -Dprefix=/opt/perl444-27-O0-5.20.0-R +C1 -DDEBUGGING
        Hit Enter and it starts the configuration.
        do  make clean or start with fresh directory (delete everything, unpack tarball, tar -zxvf perl...tar.gz )
Re: Perl install ignores -Dprefix
by neuty (Novice) on Jan 23, 2015 at 21:00 UTC

    This thread a little old, but I had this same issue and thought I'd chime in what went wrong for me.

    First, when I did my first ./Configure, I forgot to put the dash '-' before 'Dprefix'. Doing this seemed to mess up the build, since further Configures, makes, and make cleans with the correct flag didn't solve the problem. The issue resolved itself when I deleted the source folder, untarred it again from the tar file, and did the first, fresh ./Configure with the correct command:

    ./Configure -des -Dprefix=/home/user/localperl

    So if anyone is still running into this issue, try deleting the source directory and doing it again with a freshly untarred folder.

      there is also a  make realclean :)

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1087104]
Approved by marto
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others making s'mores by the fire in the courtyard of the Monastery: (5)
As of 2019-07-18 02:28 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?