++ For making this :)
Unless you are using autodie, I'd say: always use a temporary variable for the filename, to use both in the call to open and in the error message. This is to avoid having an error message that says that file A is missing, or can't be read, when you were actually trying to read file B, and to avoid looking in the wrong folder. Two examples (which I've both been guilty of):
open my $input, '<', "my_input.xml" or die "Can't open my_input.csv: $
+!"; # Whoops, my_input.xml does not exist by my_input.csv file does
my $input_file = "my_input.xml";
open my $input, '<', $input_file or die "Can't open $input_file: $!";
+# Still doesn't work but the error message is correct
my $file = get_file();
my $folder = get_folder(); # The function returned an empty string by
open my $data, '<', "$folder/$file" or die "Can't open $file; $!"; # B
+ut I see the file my folder, why does it say it doesn't exist?
my $input_file = "$folder/$input";
open my $data, '<', $input_file or die "Can't open $input_file: $!"; #
+ You'll see straightaway that you the folder is empty
Also, that's not really specific to open but try to give meaningful names to your variables. Having to use numbers is nearly always a sign that the name is wrong. $input and $output is always better than $file and $file2. $reference_data and $new_data is also better than $fh1 and $fh2.