in reply to 500 SSL Negotiation failed in perl version 5.6
Perl 5.6.1 is very ancient; it was released almost 19 years ago, which in software terms make it kind of like the sphinx.
Very few authors still support Perl 5.6. I do for a few of my releases, but most require at least 5.8. Perl 5.8.9 came out in December 2008, so still ancient, but kind of like the Roman Colosseum. If you've got 5.8.9, most recent modules will work.
But if you're going to upgrade anyway, it makes sense to upgrade to a recent officially supported version of Perl, which means Perl 5.28 or above, which came out about two years ago. Any modules you want to use should work with Perl 5.28 or above.
Edit / additional information: if the above doesn't convince you to upgrade, I'll point out that the release notes for 5.28 include four security issues. If you're using a version of Perl prior to 5.28, you're using a version of Perl with known security issues that have been addressed in more recent releases. I'm not saying that there aren't sometimes good reasons to stick with an older release, but in most cases it's a good idea to upgrade software when security fixes are available.