I have been rereading Re^3: Pointers and References and pondering variable names. It is clear from comments that different people have different conventions for how they name and structure their variable names. This is not something I have given much thought to until recently.
With the exception of constants, in the past I have generally used all lower case with an underscore sometimes between words although omitted if the name is clearly discernable. Over the last year or so I've started capitalising the first letter of each word other than the first which works better I think with more than two words.
For example $user_number and $userNumber.
Last evening I was writing some code around CRM access permissions within different business units and ended up with some poor variable names within the Perl generated web form:
crmr_5 Read access to business unit 5
crmw_3 Write access to business unit 3
crmn_1 Read and write notes access...
I'm wondering how you do it, why you do it that way and if you think it matter a great deal.