http://www.perlmonks.org?node_id=11136336


in reply to strange constants.pm warning

the sysadmin got us on v1.33 and no more warnings! TY for the comments guys. I'm still perplexed as to why the debugger broke on a false statement.

Cheers!

Replies are listed 'Best First'.
Re^2: strange constant.pm warning
by hippo (Bishop) on Sep 01, 2021 at 13:42 UTC
    the sysadmin got us on v1.33

    I've just re-read your OP and noticed that you said you were using v1.04. That's more than 20 years old! It is rather impressive that you have been using it solidly for so long and only just now hit a problem.

    Anyway, glad the upgrade has fixed it for you. Perhaps maybe consider an audit of other key modules in use on your systems with a few to further upgrades? ;-)


    🦛

      actually - not me, my client is. They keep cloning old boxes and we end up with stuff like this sometimes. Thanks for the observation I had no idea it was THAT old! I'd love to do a CPAN update on all but the client only allows them selectively.