Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number
 
PerlMonks  

Re^2: Perl API version v5.18.0 of ... does not match v5.16.0 ...

by Nightgem (Initiate)
on Jul 21, 2016 at 09:47 UTC ( #1168219=note: print w/replies, xml ) Need Help??


in reply to Re: Perl API version v5.18.0 of ... does not match v5.16.0 ...
in thread Perl API version v5.18.0 of ... does not match v5.16.0 ...

The cluster has been set up for us recently by another party... We have not changed the perl verison since we began using it.

Is there a way we can fix this?

  • Comment on Re^2: Perl API version v5.18.0 of ... does not match v5.16.0 ...

Replies are listed 'Best First'.
Re^3: Perl API version v5.18.0 of ... does not match v5.16.0 ...
by marto (Archbishop) on Jul 21, 2016 at 10:07 UTC

    File::Sync is an XS module, changing versions of perl means that such modules are not binary compatible and must be recompiled. You can't copy these things between different versions of perl, that won't work. Did you build modules in another system running a different version of perl and copy them over to this cluster? It looks like File::Sync was built with v5.18. If your supplier maintains the clusters perhaps they've changed something. In the past I've seen OS upgrades cause problems when bumping perl versions. To resolve try a manual build of the module.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1168219]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others exploiting the Monastery: (8)
As of 2019-06-17 14:55 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Is there a future for codeless software?



    Results (79 votes). Check out past polls.

    Notices?
    • (Sep 10, 2018 at 22:53 UTC) Welcome new users!