script_name is the part of the path that matched current route, not the name of the script or the raw stuff from PSGI request.
I suggest route_name as this implies the value is a string rather than an object. Also, it emphasizes that it is the route and not the script.
path_info is anything that follows that matching part, for instance a wiki article name.
Even many years ago, I never liked path_info but it was the convention and I never thought of a better alternative. Even now, I'm not sure if there's a better name and it does fit with historical convention. Maybe route_params, but just params (or param) could be confusing. I'm not sure if there is a good enough alternative to justify not using the already familiar path_info (despite that I never liked the name).
Sometimes there are good reasons to not follow historical convention. Other times, not. Most cases, a minor change to convention is the better choice. Changing script_name to route_name falls under this 3rd category.