http://www.perlmonks.org?node_id=190847


in reply to Re: Re: Re: XML::Simple and use lib
in thread XML::Simple and use lib

Hallo thraxil!

Thank you for your help, and of course I thank all of you.
With eval() I was now able to know WHAT exactly failed. And that's the output:

the error was: 
XML::Parser::Expat object version 2.30 does not match bootstrap parameter 2.27 at /usr/lib/perl5/5.6.1/i386-linux/DynaLoader.pm line 225.
Compilation failed in require at /www/htdocs/v028502/cgi-bin/Modules/XML/Parser.pm line 15.
BEGIN failed--compilation aborted at /www/htdocs/v028502/cgi-bin/Modules/XML/Parser.pm line 27.
Compilation failed in require at /www/htdocs/v028502/cgi-bin/Modules/XML/Simple.pm line 224.


Now I'm going to read through the module-lines failed in the execution.
Does anyone have an idea what is ment by "bootstrap parameter" ? Sorry about my little knowledge.
  • Comment on Re: Re: Re: Re: XML::Simple and use lib

Replies are listed 'Best First'.
Re: Re: Re: Re: Re: XML::Simple and use lib
by grantm (Parson) on Aug 20, 2002 at 10:39 UTC
    It looks to me like you have a copy of XML::Parser in your Modules directory and the system already has one installed under /usr/lib. Your one is broken - simply delete it.