Beefy Boxes and Bandwidth Generously Provided by pair Networks
There's more than one way to do things
 
PerlMonks  

Re: A SpamAssassin-Enabled POP3 Proxy

by Anonymous Monk
on Nov 01, 2002 at 12:46 UTC ( [id://209693] : note . print w/replies, xml ) Need Help??


in reply to A SpamAssassin-Enabled POP3 Proxy

This is great - I've been struggling with getting SpamAssasin to run on WinXp and this got it all going in just a few minutes! Just one question - I've installed with SpamAssassin 2.43 and my POP3Proxy log is complaining like so: configuration file "/etc/mail/spamassassin/20_body_tests.cf" requires version 2.41 of SpamAssassin, but this is code version 2.43. Maybe you need to use the -c switch, or remove the old config files? Skipping this file at C:/Perl/site/lib/Mail/SpamAssassin/Conf.pm line 246. I does the same for files: 20_compensate.cf 20_head_tests.cf 20_meta_tests.cf 20_uri_tests.cf Is this something to worry about - or is there a fix? Thanks. BarryC.

Replies are listed 'Best First'.
Re: Re: A SpamAssassin-Enabled POP3 Proxy
by McD (Chaplain) on Nov 01, 2002 at 21:39 UTC
    Barry C writes:

    This is great - I've been struggling with getting SpamAssasin to run on WinXp and this got it all going in just a few minutes!

    Glad it's working for you.

    Just one question - I've installed with SpamAssassin 2.43...

    I haven't tested against 2.43, but others have reported success.

    Based on the error message, it looks to me like you need to remove the old tests before upgrading to 2.43 - but I could be mistaken. Try zapping your entire pop3proxy directory and starting over - maybe save off your user_prefs and hostmap.txt (if any) first.

    Peace,
    -McD