Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl: the Markov chain saw
 
PerlMonks  

Perl/TK install prob (win)

by PeterM (Initiate)
on Jul 19, 2003 at 23:29 UTC ( #275953=perlquestion: print w/replies, xml ) Need Help??

PeterM has asked for the wisdom of the Perl Monks concerning the following question:

Dear perl monks,
I'd like to install and learn Perl/Tk. I've got the latest activestate perl for win32 and the Tk binaries.
TK was found at http://www.perltk.org/binaries/ptk022_5.005.tar.gz.
Instructions for getting started were found at http://www.arieba.net/icu/ptk/notes_perltk.htm.

I installed and tested perl - works fine. Tk however does not get beyond the invocation of Tk.pm This one line program fails:
use Tk;


The error:

Tk::Event object version 800.024 does not match $Tk::Event::XS_VERSION 800.022 at C:/Perl/lib/DynaLoader.pm line 249. Compilation failed at require at C:/Perl/lib/Tk.pm line 13.
The offending line in Tk.pm:
use Tk::Event ();


Any suggestions on how to get to first base?
thank you!

Replies are listed 'Best First'.
Re: Perl/TK install prob (win)
by Dog and Pony (Priest) on Jul 20, 2003 at 00:37 UTC
    I'm wondering if you got the right binaries. I looked in my own installation of ActiveState Perl and I already had Tk installed, don't recall doing that - but I might have and forgotten about it, so if it isn't included by default, try starting the Perl Package Manager (PPM) and type:
    install Tk
    instead of installing manually. Always try PPM first when using ActiveState on Windows - it doesn't always work, the modules aren't always available (or the latest), but for the common modules it is often easiest. Then you get a version specifically targetted to your Perl, and the docs are updated automatically etc.
    You have moved into a dark place.
    It is pitch black. You are likely to be eaten by a grue.
Re: Perl/TK install prob (win)
by bobn (Chaplain) on Jul 20, 2003 at 00:58 UTC

    You have, probably, perl 5.6.1 or 5.8 from Active state, but the name of your Tk implies it's for the (now pretty old) perl 5.005 - ain't gonna fly.

    --Bob Niederman, http://bob-n.com
      I aint a Perl Guru, but I have installed it on quite a few Windows XP and 98 machines lately, and used Perl Tk on all of them. Perl/Tk was just included in the Active State Perl. Perhaps you broke Tk when you tried to install Tk on a functioning Tk. That's my guess...
        My old perl + Tk install is history. After reloading, Tk is definitely in this new package and no error on "use Tk;". Thanks for the tips.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://275953]
Approved by blokhead
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (2)
As of 2021-02-26 07:12 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?