Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re: Re: Re: Re: Re: Re: Short routines matter more in OO?

by Juerd (Abbot)
on Oct 14, 2003 at 15:43 UTC ( #299150=note: print w/replies, xml ) Need Help??


in reply to Re: Re: Re: Re: Re: Short routines matter more in OO?
in thread Short routines matter more in OO?

Why are you assigning to $self->{"property$n"} and then returning $self->{property}?

That is a typo, which I then copied.

Your @_ test also makes little sense to me. If you are trying to write get/set routines, you would want to get on a single routine, set on 2, and think about throwing an error on 3 or more.

Yes. This is another typo. Should have been >=, not >. The error on 3 or more makes sense, but I usually forget those.

Fortunately, I have Attribute::Property, so I can even write working code when I'm as tired as I was when I wrote that node.

If you are going to have a lot of very similar code, then I think that autogenerating can be good.

I've put all my favourite object-property-code in Attribute::Property, together with xmath. It was originally made to allow $foo->bar = 14; syntax, but I use it now mostly because it makes creating classes much easier. (And when I'm tired, apparently this means I make less mistakes. See the other node: I made no mistake in the lines that use : Property :-))

Juerd # { site => 'juerd.nl', plp_site => 'plp.juerd.nl', do_not_use => 'spamtrap' }

Replies are listed 'Best First'.
Re: Re: Re: Re: Re: Re: Re: Short routines matter more in OO?
by tilly (Archbishop) on Oct 15, 2003 at 02:45 UTC
    I would wonder whether Attribute::Property suffers from the same issue that came up at How to redefine subroutines with Attribute::Handlers that run at BEGIN time? (subsequently reported to p5p here). Namely that attribute wrapping of functions normally is done in INIT or CHECK blocks, but those are only run once in the lifetime of the interpreter.

    Therefore code which is lazily loaded by do, require, AUTOLOAD, Apache::Reload etc won't have existed at the right time for the attributes to actually have been properly installed, therefore leading to mysteriously failing code.

    Basically what I am saying is that attributes, while they certainly win on the "cool tricks" scale, are not something that I really want to depend on.

      Therefore code which is lazily loaded by do, require, AUTOLOAD, Apache::Reload etc won't have existed at the right time for the attributes to actually have been properly installed, therefore leading to mysteriously failing code.

      Even though A::P does suffer from this, the bug caused by it is not mysterious. When you try to use the Property attribute on an anonymous sub or at some other time at which the symbol argument is not given, it croaks.

      I haven't needed to require or do my class modules or to autogenerate functions. Yet.

      Thank you for letting me know about this issue. I hope someone will find a workaround soon. When I have the time, I think I should try using Data::Swap and use the referent argument.

      Juerd # { site => 'juerd.nl', plp_site => 'plp.juerd.nl', do_not_use => 'spamtrap' }

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://299150]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others making s'mores by the fire in the courtyard of the Monastery: (4)
As of 2021-09-23 17:30 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?