Beefy Boxes and Bandwidth Generously Provided by pair Networks
more useful options
 
PerlMonks  

Re^3: annoying upgrade issue

by tomhukins (Curate)
on Jul 08, 2004 at 00:13 UTC ( #372629=note: print w/replies, xml ) Need Help??


in reply to Re^2: annoying upgrade issue
in thread annoying upgrade issue

5.005 is the 'standard' FreeBSD version, and that fact still annoys me

This isn't strictly true. In FreeBSD-4, 5.005 has been retained as the base Perl to avoid incompatibility problems for users tracking -STABLE. If the version of Perl in the base system changed, these users would also have to update Perl modules when updating the base system. This would likely result in lots of angry users and support problems.

It's easy enough to install 5.6.x from lang/perl5, or 5.8.x from lang/perl5.8 and run use.perl port. The pkg-message file for both these ports, which should be displayed after installation, documents this.

As of FreeBSD-5, Perl no longer ships in the base system to help avoid these problems. In the long term, FreeBSD aims to ship a smaller base system with more functionality moved out to packages.

Replies are listed 'Best First'.
Re^4: annoying upgrade issue
by geektron (Curate) on Jul 08, 2004 at 03:17 UTC
    corrected. i'm still on the 4.x series ( a 4.9 kernel to be specific, and once it stablilzed, up to 4.10 -- didn't want to jump 2 versions ).

    i did install from lang/perl5.8 .. just didn't use the use.perl port because i've never seen it before.

    there doesn't seem to be a manpage or perldoc for it ...

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://372629]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (4)
As of 2021-01-25 01:39 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Notices?