Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

Re^2: Can't install DBD::DB2 module

by dazzle (Sexton)
on Jan 29, 2005 at 00:25 UTC ( #426164=note: print w/replies, xml ) Need Help??


in reply to Re: Can't install DBD::DB2 module
in thread Can't install DBD::DB2 module

Mmm, it's unlikely that IBM will up and support a compiler for a single customer (unless you have a whole lot of money). The likely response you would get is "gcc is not supported on Sun; please use one of the supported compilers." (Both the Forte and Sun ONE Studio compilers are supported: DB2 supported development software, but Tanktalus is probably correct in that only the default Sun compiler is probably tested with DBD::DB2.)

Given the results of Makefile.PL, I'm guessing you built your own version of Perl rather than using the binary version that is supplied with Solaris. Veering away from the standard binary version makes it almost impossible for IBM to offer support, given the vast number of combinations they would have to be able to reproduce.

So my suggestion would be to revert to the version of Perl that comes with Solaris and try rebuilding DBI and DBD::DB2.

Failing that, you may have to rebuild Perl itself--but this time, try using the Sun compiler.

(Another resource to consider is the dbi-users mailing list at dbi-users@perl.org -- there are sure to be other people who have run into the same situation as you.)

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://426164]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (7)
As of 2019-11-19 21:24 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Strict and warnings: which comes first?



    Results (96 votes). Check out past polls.

    Notices?