http://www.perlmonks.org?node_id=437195


in reply to Solaris, Perl 5.8 and use 5.005

1) Why do they say that?

2) I used to work at a company which had the policy of having documentation in Word format, while the development was being done in *nix platforms. Needless to say, their documentation was not as good as it should be... What I'm trying to say here is that just because something is company policy doesn't mean it's a good practice (but I'm not saying that only one single version of the perl binary is bad). Anyway, I can't see any problem with removing the older perl binary for the newer one; you shouldn't have any problem with that, but see the next point and do test the apps.

3) Can't help you with your questions, but regarding "Existing apps will break", how about including a testing part in the migration process?