Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re^2: syntax error when using bind_param

by davidj (Priest)
on Apr 14, 2005 at 20:22 UTC ( #447957=note: print w/replies, xml ) Need Help??


in reply to Re: syntax error when using bind_param
in thread syntax error when using bind_param

You may be correct on that. However, my second attempt at using bind_param does use a literal and it still fails.

davidj
  • Comment on Re^2: syntax error when using bind_param

Replies are listed 'Best First'.
Re^3: syntax error when using bind_param
by davidrw (Prior) on Apr 14, 2005 at 20:29 UTC
    In the second example, you're using a literal as the value, but it's still attempting to use a placeholder (the ?) for the table name, which is what can't be done. Unfortunately, you have to construct or query with the table name:
    $qry = "SELECT * FROM $table";
    May or may not help in your case, but a very handy module is SQL::Abstract.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://447957]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (6)
As of 2019-06-17 18:35 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Is there a future for codeless software?



    Results (80 votes). Check out past polls.

    Notices?
    • (Sep 10, 2018 at 22:53 UTC) Welcome new users!