in reply to If I was forced to use only one kind of loop for the rest of my days it would be a

Definitely a foreach over a for

Wouldn't want to be stuck with a $_ in my loops now for the rest of my life. I prefer a meaningful name for the it variable