Beefy Boxes and Bandwidth Generously Provided by pair Networks
Think about Loose Coupling
 
PerlMonks  

Re^3: New PDL problem on Windows XP SP2

by syphilis (Bishop)
on Feb 15, 2006 at 07:10 UTC ( #530307=note: print w/replies, xml ) Need Help??


in reply to Re^2: New PDL problem on Windows XP SP2
in thread New PDL problem on Windows XP SP2

Looks to me that our outputs are basically similar until we get to:

cp LUT.pm ..\..\blib\lib\PDL\Graphics\LUT.pm

At that point you get some error message (the likes of which I've not seen before) whereas I simply get:

nmake -f Makefile all -nologo

Could you provide the output of 'perl -V' and tell us which compiler you're using. I hope you aren't using that free command line version of Visual Studio 7 that Microsoft have made available ... or that if you are using that compiler, then you have built your perl using that compiler. I'm not sure that I'm all that keen about troubleshooting the building of PDL with that compiler unless perl itself has been built with that compiler .... but I'll reserve judgement on that, for the moment :-)

Also, take a look at the PDL win32/INSTALL file. Is there anything there that you find to be an acceptable (alternative) way of building PDL (as opposed to the way you're currently trying to build it) ?

Cheers,
Rob
  • Comment on Re^3: New PDL problem on Windows XP SP2

Replies are listed 'Best First'.
Re^4: New PDL problem on Windows XP SP2
by syphilis (Bishop) on Feb 15, 2006 at 08:07 UTC
    Could you provide the output of 'perl -V' and tell us which compiler you're using. I hope you aren't using that free command line version of Visual Studio 7 that Microsoft have made available ... or that if you are using that compiler, then you have built your perl using that compiler.

    Sorry - when I go back and look at your original post, it seems you are using that free compiler. (I would still like to see 'perl -V', however.) Could the problem be with nmake v1.50 ? I think there should be a more recent version of nmake that came with one of the other packages that you downloaded. If so maybe give it a try instead.

    Cheers,
    Rob
      Hi Rob,

      Thanks a million.
      You gave the sollution!
      The nmake version (1.5) was not good.
      I verified and noticed that Microsoft Platform SDK also had an nmake. When I used this one, it worked :-)
      I did had to turn off slatec, but that's fine for me.
      The new PDL version compiles ok with windows XP SP2 if you use the free tools.

      Thanks,

      Jonathan

      In case you still need it: the perl -V gave me:

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://530307]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (5)
As of 2021-04-18 14:25 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?