http://www.perlmonks.org?node_id=550508

jplindstrom has asked for the wisdom of the Perl Monks concerning the following question:

I'm trying to install a module which uses Module::Build on a Red Hat Enterprise Linux ES release 3 (Taroon Update 4) machine. However, installing Module::Build itself fails with the following message:

# running Build.PL Can't locate the perl binary used to run this script in (/usr/bin /usr +/bin /usr/bin /usr/kerberos/sbin /usr/kerberos/bin /usr/local/sbin /u +sr/local/bin /sbin /bin /usr/sbin /usr/bin /usr/X11R6/bin /root/bin)

Googling that error message only gives me the source page of Module::Build on search.cpan.org :)

So I have read the code in Module::Build but not researched further what it could be; I thought I'd ask whether this rings a bell for anyone before spending any more time.

Environment:

which perl /usr/bin/perl

perl -V ... /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0

/J