Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

Re^5: CGI-Perl:: Location for saving the GD output

by cool (Scribe)
on Sep 11, 2006 at 11:24 UTC ( #572332=note: print w/replies, xml ) Need Help??


in reply to Re^4: CGI-Perl:: Location for saving the GD output
in thread CGI-Perl:: Location for saving the GD output

Hi Tinita!!

Following are the sequence of installation I tried...

I have installed HTML-Template-Compiled-0.73 but while doing 'make install' it showed up "no DHTML installed"
PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_h +arness(0, 'blib/lib', 'blib/arch')" t/*.t t/01_HTML-Template-Compiled....ok t/02_version...................ok t/03_param.....................ok t/04_out_fh....................ok t/05_filter....................ok t/06_dyn_include...............ok t/07_formatter.................ok t/08_global_vars...............ok t/09_wrong.....................ok t/10_if_else...................ok t/11_dhtml.....................ok 1/2 skipped: no DHTML installed t/12_path......................ok t/13_loop......................ok t/14_scalarref.................ok t/15_comment...................ok t/16_switch....................ok t/17_escape....................ok t/18_objects...................ok t/19_query.....................ok t/20_precompile................ok t/21_while.....................ok t/22_pod.......................skipped all skipped: Test::Pod 1.00 required for testing POD t/23_tagstyles.................ok t/24_pod_cover.................skipped all skipped: Test::Pod::Coverage required for testing pod cove +rage All tests successful, 2 tests and 1 subtest skipped. Files=24, Tests=96, 17 wallclock secs ( 5.15 cusr + 0.96 csys = 6.11 + CPU)
and then for make install
[root@calvin HTML-Template-Compiled-0.73]# make install Writing /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/auto/HT +ML/Template/Compiled/.packlist Appending installation info to /usr/lib/perl5/5.8.5/i386-linux-thread- +multi/perllocal.pod

So after this I tried installing HTML-Template-Compiled-Plugin-InlineImage-0.02

#perl Makefile.PL Writing Makefile for HTML::Template::Compiled::Plugin::InlineImage

root@calvin HTML-Template-Compiled-Plugin-InlineImage-0.02# make Manifying blib/man3/HTML::Template::Compiled::Plugin::InlineImage.3pm /usr/bin/perl "-Iblib/arch" "-Iblib/lib" Build.PL Build Can't locate Module/Build.pm in @INC (@INC contains: blib/arch blib/lib /usr/lib/perl5/5.8.5/i386-linux-thread-multi /usr/lib/perl5/5.8.5 /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.4/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.3/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.2/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 /usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 /usr/lib/perl5/vendor_perl .) at Build.PL line 3. BEGIN failed--compilation aborted at Build.PL line 3. make: *** Build Error 2

Replies are listed 'Best First'.
Re^6: CGI-Perl:: Location for saving the GD output
by davorg (Chancellor) on Sep 11, 2006 at 11:51 UTC

    The "errors" here are pretty clear if you read them.

    I have installed HTML-Template-Compiled-0.73 but while doing 'make install' it showed up "no DHTML installed"

    That's not an error. It's just saying that some of the tests weren't run because you don't have the required modules installed.

    Can't locate Module/Build.pm in @INC

    That's a little more serious. Looks like you Don't have Module::Build installed - although that's a little strange as the Makefile shouldn't be using Module::Install, it should be using ExtUtils::MakeMaker. Did you definitely run "perl Makefile.PL" and not "perl Build.PL"?

    In any case, try install Module::Build and trying again.

    --
    <http://dave.org.uk>

    "The first rule of Perl club is you do not talk about Perl club."
    -- Chip Salzenberg

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://572332]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others romping around the Monastery: (3)
As of 2020-02-29 01:51 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    What numbers are you going to focus on primarily in 2020?










    Results (128 votes). Check out past polls.

    Notices?