Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re^3: Install Module issue

by syphilis (Archbishop)
on Apr 30, 2007 at 11:58 UTC ( [id://612752] : note . print w/replies, xml ) Need Help??


in reply to Re^2: Install Module issue
in thread Install Module issue

The command line version of "ppm" is still there if you want it, but it can be hard to find

Hmmm ... I just ran ppm install Win32-API in a fresh installation of the latest ActiveState build (820) and it installed just fine - thankfully without launching any GUI crap at all. This seems to be in contradiction to your post - or have I misunderstood something ?

Cheers,
Rob

Replies are listed 'Best First'.
Re^4: Install Module issue
by jettero (Monsignor) on Apr 30, 2007 at 13:00 UTC

    The ppm shell still attaches to the win32 console, so you'll get a dos window either way (iirc). If you start ppm without any arguments, it'll pop up the GUI — unless you have an older version of active perl. If you have the latest build, then I suspect you gave it install arguments and it didn't bother with the GUI since it already knew what you wanted.

    P.S. Don't be too down on the GUI. It lowers the bar for new perl nerds and it's not a bad GUI at that.

    -Paul

      then I suspect you gave it install arguments and it didn't bother with the GUI

      Aaah ... yes, if you run 'ppm' without args it now launches the GUI console (whereas it used to put you into the ppm interactive shell). Now I understand what rodion was saying.

      Cheers,
      Rob