Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number
 
PerlMonks  

Re: Image::Magick

by jlawrenc (Scribe)
on Mar 12, 2001 at 20:16 UTC ( #63840=note: print w/replies, xml ) Need Help??


in reply to Image::Magick

1 - The reference to -lfpx is for FlashPix library - whatever that is!

2 - You might have installed ImageMagick into a different prefix than the default (/usr/local ?) In which case, when you run "perl Makefile.PL" you have to supply a bit more info now.

Call it as: perl Makefile.PL "INC=-I/path/to/ImageMagick/include" "LIB=-L/path/to/imagemagic/lib"

You can ignore the -lfpx as it should be harmless. You may need to rebuild ImageMagick with no support for FPX? Watch your "gcc" statements as they go across the screen. Does it look like there is enough path info for LIBs and INCs to get the job done?

Now you might need more stuff in the Makefile.PL command. I will be testing it out myself later on today. But in the mean time check that out if you have a sec.

Jay

Replies are listed 'Best First'.
Re: Re: Image::Magick - one step forward, two back?
by jlawrenc (Scribe) on Mar 13, 2001 at 20:46 UTC
    I have spent a bit of time on this problem and am more perplexed now than I was before starting. Ooops.

    First I'll offer how I build MY version of ImageMagick at the momement. I may change this after further experimentation but this is at least more than what I am after:

    PREFIX=/opt export CCFLAGS="-I$PREFIX/include/freetype2" export LDFLAGS="-L$PREFIX/lib" ./configure --prefix=$PREFIX \ --enable-shared \ --disable-static \ --with-modules \ --with-largefiles \ --with-magick-plus-plus \ --with-threads \ --enable-lzw=yes \ --without-fpx \ --with-perl=$PREFIX/bin/perl \ >logs/ImageMagick-config
    After running all that I get a good build of the ImageMagick libraries and PerlMagick. Yaaah.

    However, CPAN'ing the more recent version of PerlMagick leads me into the confusion. I am getting complaints about all sorts of unknown struct members and types during make.

    Magick.xs: In function `SetAttribute':
    Magick.xs:1392: structure has no member named `pen'
    Magick.xs: In function `XS_Image__Magick_Mogrify':
    Magick.xs:3693: `AffineMatrix' undeclared (first use in this function)
    Magick.xs:3693: (Each undeclared identifier is reported only once
    Magick.xs:3693: for each function it appears in.)
    Magick.xs:3693: parse error before `affine'
    Magick.xs:4351: structure has no member named `text'
    Magick.xs:4363: structure has no member named `geometry'
    ...yadda yadda
    
    Unfortunately I don't have heaps of time to figure out what has gone awry but when I do, you'll hear from me. :)

    Jay

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://63840]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others about the Monastery: (1)
As of 2022-05-18 04:42 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Do you prefer to work remotely?



    Results (68 votes). Check out past polls.

    Notices?