Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Installing GD::Graph

by pyc (Initiate)
on Mar 02, 2008 at 10:24 UTC ( #671478=perlquestion: print w/replies, xml ) Need Help??

pyc has asked for the wisdom of the Perl Monks concerning the following question:

I'm really newbie to Perl and I hope nobody here minds if I ask a stupid question. But I would rather not say it's stupid because I'm totally stuck and I have fairly good knowledge in computing. So please help me install GD::Graph extension because it's needed to RT installation. Here's what I get when I try to install it:
t/bugfixes......1/33 Problems reading t/images/logo.gif (tried: GIF gi +f) at t/bugfixes.t line 42 # Failed test '_read_logo_file succeeds for gif with file extension' # at t/bugfixes.t line 42. # Failed test 'The object isa GD::Image' # at t/bugfixes.t line 44. # The object isn't defined Problems reading t/images/logo_gif_noext (tried: gif) at t/bugfixes.t +line 46 # Failed test '_read_logo_file succeeds for gif without file extensi +on' # at t/bugfixes.t line 46. # Failed test 'The object isa GD::Image' # at t/bugfixes.t line 48. # The object isn't defined Unsuccessful open on filename containing newline at /usr/lib/perl5/GD. +pm line 125. Problems reading t/images/logo_xbm_noext (tried: libgd best-guess) at +t/bugfixes.t line 46 # Failed test '_read_logo_file succeeds for xbm without file extensi +on' # at t/bugfixes.t line 46. # Failed test 'The object isa GD::Image' # at t/bugfixes.t line 48. # The object isn't defined # Looks like you failed 6 tests of 33. t/bugfixes...... Dubious, test returned 6 (wstat 1536, 0x600) Failed 6/33 subtests t/colour........ok t/data..........ok t/error.........ok t/use...........ok Test Summary Report ------------------- t/bugfixes.t (Wstat: 1536 Tests: 33 Failed: 6) Failed tests: 4-7, 22-23 Non-zero exit status: 6 Files=6, Tests=118, 1 wallclock secs ( 0.05 usr 0.00 sys + 0.32 cus +r 0.04 csys = 0.41 CPU) Result: FAIL Failed 1/6 test programs. 6/118 subtests failed. make: *** [test_dynamic] Error 255 BWARFIELD/GDGraph-1.44.tar.gz /usr/bin/make test -- NOT OK //hint// to see the cpan-testers results for installing this module, t +ry: reports BWARFIELD/GDGraph-1.44.tar.gz Running make install make test had returned bad status, won't install without force Failed during this command: BWARFIELD/GDGraph-1.44.tar.gz : make_test NO
t/images/logo.gif exist.

Replies are listed 'Best First'.
Re: Installing GD::Graph
by roboticus (Chancellor) on Mar 02, 2008 at 11:21 UTC
    pyc:

    You should use code tags (<c>like this</c>)around preformatted things like code and error messages, and paragraph breaks to start new paragraphs, like this:<p>

    You can see a list of those (and more) at the bottom of the preview window.

    <b>Note:</b> You can go back and fix (update) your message if you need to. However, if you <i>do</i> update your node, you should add a note to your node letting people know that you changed it. You do this so that if anyone replied to your original node, then people reading the thread can make sense of it. Otherwise some replies will look totally wrong.

    ...roboticus

    Update: Added "update" information, as suggested by (the somewhat impolite) roboticus.

    Update: Added example formatting tags for bold and italics just because...

      Hey doofus! If you're gonna write an explanatory node, why didn't you mention the importance of updates?

      ...roboticus

Re: Installing GD::Graph
by syphilis (Archbishop) on Mar 02, 2008 at 11:50 UTC
    Looking at the error messages ... I'm inclined to speculate that the only problem relates to gif images. That being the case, the failures could be ignored (iff one is not going to use gif images).

    Cheers,
    Rob
Re: Installing GD::Graph
by zentara (Archbishop) on Mar 02, 2008 at 15:18 UTC
    There is a chain of dependencies that you need to check. It starts with libgd, then the GD module, then GD::Graph.

    So you may need to recompile libgd ( with the latest version), then rebuild GD, then rebuild GD::Graph to get gif support. From the GD readme:

    libgd can now be built with support for one or more of the PNG, GIF, +XPM or JPEG formats. If one or more of these formats are not support +ed by libgd, then the corresponding GD::Image methods will be unavail +able. ....... + As of libgd 2.0.33, GIF support is always compiled in, so (for the +time being!) this is a safe fallback.

    I'm not really a human, but I play one on earth. Cogito ergo sum a bum
Re: Installing GD::Graph
by ChemBoy (Priest) on Mar 03, 2008 at 01:23 UTC

    If you're not using XPM or GIF, you can totally ignore those errors, and just force install GDGraph. If you are planning to use GIF, then you might want to check if your libgd is configured to support that format. I suspect RT uses PNG anyway, so you should be fine regardless.



    If God had meant us to fly, he would *never* have given us the railroads.
        --Michael Flanders

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: perlquestion [id://671478]
Approved by Corion
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others exploiting the Monastery: (2)
As of 2022-09-29 07:25 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    I prefer my indexes to start at:




    Results (125 votes). Check out past polls.

    Notices?