Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Re^2: How to uninstall module of perl

by calvinlyp (Novice)
on May 23, 2009 at 14:27 UTC ( #765829=note: print w/replies, xml ) Need Help??


in reply to Re: How to uninstall module of perl
in thread How to uninstall module of perl

sorry i not very familiar what is ppm. i am using ubuntu 8.10 with perl version 5.10

by the way how to know where i can delete the files of the module i install?it is because it seems to appear at multiple location of the module i installed. fro eg /usr/lib/perl/5.10/ is in this particular dir, next i also have /usr/local/share/perl/5.10.0 . thus it make me confuse where does the modules go to?

if i now download an old version and i install it, will it overwrite my current latest version?

Replies are listed 'Best First'.
Re^3: How to uninstall module of perl
by ig (Vicar) on May 24, 2009 at 05:40 UTC

    ppm is the Perl Package Manager that comes with ActiveState perl. This build of perl is popular for Windows system but is also available for other system.

    There are several ways you might have installed your modules. If you post the details you may get more specific answers to your questions.

    In general, you should uninstall the modules with the same tool that you used to install them.

    If you used the Ubuntu package manager to install an Ubuntu package, then you should probably use the same package manager to uninstall the package. Simply removing the files may work from perl's perspective but it may confuse your package manager, possibly causing problems in the future. I would uninstall the newer package before installing an older one myself, but someone more familiar with the Ubuntu platform may be able to give you shortcuts.

    If you installed packages directly from CPAN with the cpan or cpanp commands, the CPAN or CPANPLUS modules or by manually downloading from CPAN and following the install directions, then you can follow the advice given in the first response to your post and its linked documents and posts.

      in the first place i installed using the specified version of the module.i use the steps as shown below to install.

      perl Makefile.PL

      make

      make test

      make install

      recently i went to update by using the following method: cpan -i MIME::Base64

      (can i know the above command i use is to install the latest version from CPAN right?)

        Yes, cpan -i MIME::Base64 will have installed the latest version from CPAN.

        If you download the version of the module you want, you should be able to remove the current (newer) version and install the older version with:

        perl Makefile.PL make make test make install UNINST=1

        Setting UNINST=1 when you install should cause the existing version to be uninstalled.

Log In?
Username:
Password:

What's my password?
Create A New User
Domain Nodelet?
Node Status?
node history
Node Type: note [id://765829]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (5)
As of 2021-11-30 20:34 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?