Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses
 
PerlMonks  

Re: NTLM authentication fails with WWW:Mechanize, fine with LWP::UserAgent

by reasonablekeith (Deacon)
on Jun 02, 2009 at 11:52 UTC ( #767566=note: print w/replies, xml ) Need Help??


in reply to NTLM authentication fails with WWW:Mechanize, fine with LWP::UserAgent

I'm still banging my head on this one. I've tried using LWP to generate a valid authentication string, and passing that in the headers of a mech request, but that's not working either, presumably because I'm being issued another challenge.

Any pointers would be much appreciated.

---
my name's not Keith, and I'm not reasonable.
  • Comment on Re: NTLM authentication fails with WWW:Mechanize, fine with LWP::UserAgent

Replies are listed 'Best First'.
Re^2: NTLM authentication fails with WWW:Mechanize, fine with LWP::UserAgent
by Corion (Pope) on Jun 02, 2009 at 11:56 UTC

    You will need a version of WWW::Mechanize of at least 1.52 or greater, as the changes in the credentials API of LWP::UserAgent did not get mirrored by similar changes in WWW::Mechanize until then.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://767566]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others rifling through the Monastery: (9)
As of 2019-12-10 12:47 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    No recent polls found

    Notices?