http://www.perlmonks.org?node_id=813170

philharbour has asked for the wisdom of the Perl Monks concerning the following question:

Hi there, Can anyone help with makemaker? I'm wanting to install DBI and DBD to custom directories. I've downloaded and unzipped the tar's. Then using Perl Makefile.pl with the PREFIX parameter which has worked great for DBI. The perl5 perl_site etc all in the custom directory. The problem is when i then try to build DBD::Oracle it throws up an error that the DBI version is too old. I've also been able to run a perl script using the "use lib blah blah blah' and checked that the DBI version is indeed correct at this location. I've updated the Environment variable PERLLIB to reflect the newly installed DBI module location but no joy Any ideas? Thanks for any pointers, or advice on how i should go about installing DBI and DBD::Oracle to a custom directory Regards Phil