http://www.perlmonks.org?node_id=857137


in reply to Re^3: broke my perl? :(
in thread broke my perl? :(

I think on Debian (and thus Ubuntu), apt-get and some other system-relevant programs still rely on /usr/bin/perl working. This would mean that installing any package likely won't work on that system.

I think that Debian plans/planned to remove the dependency on perl for apt-get, so maybe that will work in a recent version of Debian/Ubuntu. Restoring from backup would be the approach that's more likely to work.