Don't you think the "foreach" comment is nitpicking a bit? It's an alias to "for" and when performing the loop the the Perlish way the phrase "for each element" makes more sense than "for element". Meanwhile, when using it the repressed memory inducing, nightmarish C-style way, the phrase "for this series of numbers" is a better fit. In my experience, "foreach" is easier for people new to programming to grasp and it makes it easier to wean C-junkies off of the C-styled for loops.
Elda Taluta; Sarks Sark; Ark Arks