Beefy Boxes and Bandwidth Generously Provided by pair Networks
Just another Perl shrine
 
PerlMonks  

Re: Why isn't a newer version of a module installable from cpan?

by Khen1950fx (Canon)
on Feb 05, 2011 at 08:51 UTC ( #886372=note: print w/replies, xml ) Need Help??


in reply to Why isn't a newer version of a module installable from cpan?

If you look at the Makefile.PL, you'll find that PALANT is still listed as the author, so when you try to download it from CPAN, the PALANT v0.4 supplants MISHOO's v0.5, even though v0.5 is the current version.
  • Comment on Re: Why isn't a newer version of a module installable from cpan?

Replies are listed 'Best First'.
Re^2: Why isn't a newer version of a module installable from cpan?
by Anonymous Monk on Feb 05, 2011 at 10:15 UTC
    If you look at the Makefile.PL, you'll find that PALANT is still listed as the author, so when you try to download it from CPAN, the PALANT v0.4 supplants MISHOO's v0.5, even though v0.5 is the current version.

    Nice theory, got anything to back it up?

      Yes. In addition to the Makefile.PL, PALANT is still listed as the author in the README and META.yml.
        Um, how is that proof that its the reason 02packages.details.txt.gz/modlist doesn't list it, even though its been shown it should?

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://886372]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others studying the Monastery: (11)
As of 2018-11-13 17:47 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My code is most likely broken because:
















    Results (158 votes). Check out past polls.

    Notices?